Registrierung
leer
leer
newposts
Users
search
FAQ
Login
Start

Hallo Gast, und Willkommen im Forum. Sie müssen sich einloggen oder registrieren, um alle Funktionen nutzen zu können.


PN's Forum \ Computer \ Software \ Betriebssysteme \ Windows \ Win2k3 Web - Einrichtung eines VPN Zuganges


 Poison Nuke  *

#1 Verfasst am 29.11.2008, um 10:21:20



Hallo,

ich versuche gerade mal testweise, auf meinen Cluster über VPN zuzugreifen.

Aufgebaut ist das ganze so, dass ich einen Cluster habe, der intern erstmal ganz normale private IPs hat. Und da ist noch ein Server angeschlossen, der eine Netzwerkkarte zum Cluster hat und eine Netzwerkkarte zum Internet mit zwei öffentlichen IPs inkl. Domain.

So, um jetzt einen Knoten im Cluster zu erreichen, muss ich bisher mich erstmal per RD auf den Server (WS03) verbinden um dann von dort entweder eine erneute RD Sitzung zu öffnen oder halt anderweitig im Netzwerk zu arbeiten.

Ziel wäre jetzt, einen VPN Zugang einzurichten.

Das hab ich auch versucht, in dem ich Routing und RAS über den Assistenten konfiguriert habe und dabei die standardmäßigen Option mehr oder weniger gelassen.
Naja, nach Beendigung des Assistenten wurde dann Routing und RAS aktiviert...und bam, der Server war nicht mehr erreichbar. Weder per ICMP, FTP, HTTP oder RDP.

Hab dann von einem Kollegen erstmal Routing wieder deaktivieren lassen.

Eine Firewall kann es nicht sein, weil Routing und Firewall definitiv unmöglich zusammen laufen können.
Da aber auch nicht mehr als ein VPN Zugang eingerichtet wurde, erkenn ich gerade nicht so ganz das Problem, normalerweise ist wenigstens die IP noch erreichbar vom Server.


hat einer von euch zufällig eine Idee?


greetz
Poison Nuke

 Poison Nuke  *

#2 Verfasst am 29.11.2008, um 20:21:17



arg...bei der Auswahl der Netzwerkkarte, die die Verbindung zum Internet hat, hab ich vergessen den Haken bei "Paketfilter auf dieser Schnittstellen aktivieren" vergessen zu entfernen:L
Damit hatte die Netzwerkkarte nur noch PPTP Datenverkehr angenommen.


Obwohl ich jetzt immernoch keine VPN Verbindung hinbekomme...hm


greetz
Poison Nuke

 Poison Nuke  *

#3 Verfasst am 29.11.2008, um 21:21:50



also so langsam wird es schon komisch :Y


Also der VPN Zugang ist eingerichtet über Routing und RAS
- extra Nutzer für VPN mit Einwählberechtigung über RAS-Richtlinien
- DHCP Server wurde auf dem Server installiert, Relay Agent leitet VPN Anfragen an diesen weiter
- DNS Server wurde auch installiert
- RAS Richtlinie für VPN Verbindungen mit der eigens erstellten Nutergruppe wurde eingerichtet
- Unter Eigenschaften von Routing und RAS wurde DHCP eingestellt, und die Haken bei IP Routing + RAS Verbindungen zulassen + BC Namensauflösung wurden gesetzt



Ich versuche mich von Windows Vista aus, welches in einem lokalen Netzwerk, dass über einen billigen NAT Router ans Internet angeschlossen ist, mit diesem Server auf dessen öffentliche IP Zu verbinden...aber direkt nach dem Klicken auf "Verbinden" kommt schon die Meldung, dass die Verbindung nicht hergestellt werden kann, aber warum sagt Vista nicht...


greetz
Poison Nuke

Cattivo

#4 Verfasst am 29.11.2008, um 21:24:32



Nur mal kurz. Ich kann mich intern nicht über meinen Router extern mit meinem Server verbinden. Das läßt der Router nicht zu. Hatte mir damals aus Verzweifelung eine ISDN Leitung gelegt.


Gruß Markus
Mein Heimkino

Cattivo

#5 Verfasst am 29.11.2008, um 21:26:39



Ach und das noch:


Zitat:

Es kommt auf den Typ des VPNs an. Beispiele:

PPTP: 1723/TCP + Protokoll (NICHT Port) 47 (GRE - Generic Routing
Encapsulation)
L2TP: 1701/UDP + 500/UDP (ISAKMP)

Ausserdem verwendet werden für IPSec:
Protokoll 50 (NICHT Port) - ESP (Encapsulated Security Payload)
Protokoll 51 (NICHT Port) - AH (Authentication Header)





Gruß Markus
Mein Heimkino

 Poison Nuke  *

#6 Verfasst am 29.11.2008, um 21:39:12



aber meinem Router sollte doch egal sein, was er rüberleitet, sind ja im Endeffekt alles TCP Protokolle oder ist GRE eigenständig und unabhängig von TCP?

wäre ja blöd, wenn mein DSL Router das verhindert :cut



greetz
Poison Nuke

Cattivo

#7 Verfasst am 29.11.2008, um 21:43:45



Ich kenne ja deine Netzstruktur nicht. Wenn der Router jedoch merkt, dass du in das eigentliche Netz über einen Umweg zurück möchtest, kann er das sehr wohl verhindern.


Gruß Markus
Mein Heimkino

 Poison Nuke  *

#8 Verfasst am 29.11.2008, um 22:00:50



nein, ganz und gar nicht:








greetz
Poison Nuke

Cattivo

#9 Verfasst am 29.11.2008, um 22:05:15



Eine Fehlerquelle ausgeschlossen.


Poison schrieb:
aber direkt nach dem Klicken auf "Verbinden" kommt schon die Meldung, dass die Verbindung nicht hergestellt werden kann, aber warum sagt Vista nicht



Das könnte dann auch an deiner Netzwerkeinrichtung deines Rechners liegen. Vista bietet ja mehrere Möglichkeiten an und je nach Auswahl werden bestimmte Dinge einfach gesperrt/nicht gestartet. Leider auch wieder nur eine Vermutung.



Gruß Markus
Mein Heimkino

 Poison Nuke  *

#10 Verfasst am 30.11.2008, um 10:09:52



alles klar, es liegt an dem blöden DSL Router...der lässt die Protokolle einfach nicht durch:Y

bin gerade über UMTS an meinem Laptop online und siehe da, es funzt auf Anhieb:hail

das geniale ist, ich surfe jetzt bei aktiver VPN Verbindung auch über den andere lokale Netz....also alles verhält sich echt so, als hätte ich einen direkten Anschluss an das Clusternetzwerk. Daher auch der interessante Tracert, wie schon im anderen Thread gezeigt:


8)

hätte gar nicht gedacht, dass man VPN so einfach zum Laufen bekommt, weil die Tutorials sind immer so extrem umfangreich. Man muss halt nur mit der Sicherheit aufpassen, dass von außen kein anderer reinkommt. Habe dafür ja extra eine neue Nutzergruppe angelegt die nirgendwo Mitglied ist, aber nur diese Nutzergruppe darf sich am VPN anmelden. Somit müsste einer dann schon das VPN Passwort haben, um erstmal ins Netz reinzukommen und dann braucht er noch die anderen Passworter, um auf die Rechner zu kommen.



Nur wie macht man das mit dem DSL Router :?


greetz
Poison Nuke

Cattivo

#11 Verfasst am 30.11.2008, um 16:05:18



Das hängt auch von deinem Router ab, ob der das überhaupt unterstützt. Das kann nicht jeder.


Zitat:

Dennoch klappt nicht mit allen Routern die Verbindungsaufnahme. Damit der VPN-Server hinter dem Router erreichbar ist, muss der Router für eintreffende PPTP-Verbindungen diese ins lokale Netz weiterleiten (Port Forwarding) bzw. die Firewall diese durchlassen. PPTP verwendet jedoch nicht TCP/UDP sondern GRE (Generic Routing Encapsulation) als Transportprotokoll (Protokollnummer 47). Dies können nicht alle Router an einen VPN-Server weiterleiten. Viele Hersteller meinen mit VPN-Fähigkeit lediglich, dass der Router mit einem VPN-Server verbinden kann, nicht aber vor einem VPN-Server funktioniert.




Gruß Markus
Mein Heimkino

 Poison Nuke  *

#12 Verfasst am 30.11.2008, um 16:15:19



ups, hatte hier das Update vergessen :X

zudem wäre das der falsche Artikel, weil ich ja RAUS gehe aus dem lokalen Netz und keine VPN Verbindungen reinkommen...außerdem hat der Router die Optionen für VPN Passtrough, also PPTP und IPSec Verbindungen werden durchgelassen.

Hab nämlich das ganze über meinen WinXP Rechner hier im LAN getestet, da ging es wunderbar :hail
nur Windows Vista spinnt rum.

Das interessante ist aber, dass es scheinbar ein paar mehr Probleme hat...wenn ich eine VPN Verbindung nicht sofort verbinden will, sondern diese nur gespeichert werden will, macht er das trotzdem nicht, er versucht sofort zu verbinden, zeigt sofort einen Fehlschlag, bietet keine Diagnose an und gespeichert wird auch nix, egal wie oft man das anklickt :cut




greetz
Poison Nuke

Cattivo

#13 Verfasst am 30.11.2008, um 16:25:23



Hilft dir das evtl. weiter?


Zitat:

Das liegt eventuell auch mit an der Firewall, die eingesetzt wird. Damit meine ich nicht Deine, sondern die der Gegenstelle.

Bei mir ist es so, dass ich durch eine Cisco Pix (min. 5 Jahre alt) muss.

XP benutzt MS-CHAPv1 (Authentifizierungsprotokoll) -> welches auch mit ner alten Pix funktioniert.
Vista benutzt MS-CHAPv2 (v1 gibts nicht mehr) -> welches die alten Pixen nicht mehr können und mangels fehlendem Cisco Support auch nicht mehr können werden. Tolle Wurst!

Meiner Recherche nach handelt es sich um Pixen der Modelle 501, 506 und 515




Gruß Markus
Mein Heimkino

 Poison Nuke  *

#14 Verfasst am 30.11.2008, um 16:30:18



hatte auch im mcseboard schon einer vermutet, aber ich habe ja diese Option im VPN aktiv und das sollte laut deren aussage unabhängig vom Router sein...weil das läuft ja auch über das gleiche Protokoll ab :Y


greetz
Poison Nuke

PN's Forum \ Computer \ Software \ Betriebssysteme \ Windows \ Win2k3 Web - Einrichtung eines VPN Zuganges


- Zurück zur Homepage - Eigene Beiträge - Neue Beiträge - Wer ist online? - Impressum - Datenschutz - Statistiken -



Board coded and provided by: Poison Nuke
Copyright 2007-2014, Robert Menger