Registrierung
leer
leer
newposts
Users
search
FAQ
Login
Start

Hallo Gast, und Willkommen im Forum. Sie müssen sich einloggen oder registrieren, um alle Funktionen nutzen zu können.


PN's Forum \ Computer \ Software \ Betriebssysteme \ Windows \ Kein RDP Zugriff von Windows Vista / 7 Client auf Windows Server 2008 (R2)


 Poison Nuke  *

#1 Verfasst am 01.04.2011, um 20:41:16



Wenn man sich von einem Windows 7 oder einem Windows Vista Rechner versucht über RDP an einem Server 2008 anzumelden, bekommt man trotz korrekter Anmeldedaten (auch mit korrekter Domain) folgenden Fehler:


Quellcode
"Der Anmeldeversuch ist fehlgeschlagen" ( "The logon attempt failed" )



das interessante ist, wenn man sich von Windows XP oder Server 2003 mit RDP auf den 2008er Server verbinden will, funktioniert das einwandfrei.


Im Ereignisprotokoll von 2008 bekommt man folgenden Fehler:


Zitat:

Fehler beim Anmelden eines Kontos.

Antragsteller:
Sicherheits-ID: NULL SID
Kontoname: -
Kontodomäne: -
Anmelde-ID: 0x0

Anmeldetyp: 3

Konto, für das die Anmeldung fehlgeschlagen ist:
Sicherheits-ID: NULL SID
Kontoname: Administrator
Kontodomäne: SERVERDOM

Fehlerinformationen:
Fehlerursache: Unbekannter Benutzername oder ungültiges Kennwort.
Status: 0xc000006d
Unterstatus:: 0xc000006a

Prozessinformationen:
Aufrufprozess-ID: 0x0
Aufrufprozessname: -

Netzwerkinformationen:
Arbeitsstationsname: UNIMATRIX
Quellnetzwerkadresse: -
Quellport: -

Detaillierte Authentifizierungsinformationen:
Anmeldeprozess: NtLmSsp
Authentifizierungspaket: NTLM
Übertragene Dienste: -
Paketname (nur NTLM): -
Schlüssellänge: 0

Dieses Ereignis wird beim Erstellen einer Anmeldesitzung generiert. Es wird auf dem Computer generiert, auf den zugegriffen wurde.

Die Antragstellerfelder geben das Konto auf dem lokalen System an, von dem die Anmeldung angefordert wurde. Dies ist meistens ein Dienst wie der Serverdienst oder ein lokaler Prozess wie "Winlogon.exe" oder "Services.exe".

Das Anmeldetypfeld gibt den jeweiligen Anmeldetyp an. Die häufigsten Typen sind 2 (interaktiv) und 3 (Netzwerk).

Die Felder für die Prozessinformationen geben den Prozess und das Konto an, für die die Anmeldung angefordert wurde.

Die Netzwerkfelder geben die Quelle einer Remoteanmeldeanforderung an. Der Arbeitsstationsname ist nicht immer verfügbar und kann in manchen Fällen leer bleiben.

Die Felder für die Authentifizierungsinformationen enthalten detaillierte Informationen zu dieser speziellen Anmeldeanforderung.
- Die übertragenen Dienste geben an, welche Zwischendienste an der Anmeldeanforderung beteiligt waren.
- Der Paketname gibt das in den NTLM-Protokollen verwendete Unterprotokoll an.
- Die Schlüssellänge gibt die Länge des generierten Sitzungsschlüssels an. Wenn kein Sitzungsschlüssel angefordert wurde, ist dieser Wert 0.







je nach Konfiguration des 2008er Servers (z.B. wenn Remote Desktop Services installiert sind mit Zertifikaten) können folgenden Hinweise hilfreich sein:
http://support.microsoft.com/kb/954397/en-us




allerdings nicht im Falle eines frisch installierten Windows Server 2008 ohne jegliche Einstellungen, außer IP und Passwort. Dieser hat im übrigen RDP für alle Versionen aktiviert, sonst könnte sich klarerweise XP und 2003 nicht verbinden.




das interessante ist, auf einigen Windows 7 PCs funktioniert das ganze. Leider konnte ich auch nach 5 Stunden Google und eigentlich tausend mal die gleiche Frage aber sogut wie nie einer Antwort bisher nur eine temporäre Lösung finden:



Start - Ausführen - "netplwiz" -> Erweitert -> Kennwörter verwalten -> Windows Anmeldeinformationen hinzufügen

Quellcode
TERMSRV/ip.des.2k8.srv




Nur es kann keine Lösung sein, für jeden Server dauernd die Passwörter zu hinterlegen, zumindest nicht in meinem Fall, wo ich von dem Win 7 PC mich mit tausenden 2008er Servern verbinden muss.





leider habe ich im Moment auch keine Idee wo der Unterschied zwischen meiner Win 7 Arbeitsstation und der von anderen ist wo es funktioniert. Igendwas habe ich wohl "verkonfiguriert".

Hat einer von euch vllt eine Idee, wo das ganze hängen könnte?
Ich vermute ein wenig, es hat was mit SSL Zertifikaten und Kerberos zu tun. Aber ich kann da nicht wirklich etwas finden das ich einstellen könnte bzw das ich mal hätte umstellen können. Z.B. in den Administrativen Vorlagen hab ich gar nichts eingestellt.


greetz
Poison Nuke

bearbeitet von Poison Nuke, am 01.04.2011, um: 20:41:40


endurance

#2 Verfasst am 01.04.2011, um 21:21:40



Hatte ich noch nicht in der Form wenn es mit "alten" Clients funzt evtl ein Problem mit NTLMv2?
Backup und spiel mal mit
Start -> run -> secpol.msc -> Security Settings -> Local Policies -> Security Options -> Network security: LAN Manager authentication level -> Send NTLM response only

Arbeitest Du mit DynDNS und DHCP? Hatte ähnliche probs mal mit Win7 als mein DHCP server nicht mehr ging...

stochern im Nebel richtig helfen kann ich glaube ich nicht

Grüße aus dem 27Grad warmen Bozen ;)



http://www.mtb-la-palma.de

 Poison Nuke  *

#3 Verfasst am 01.04.2011, um 21:58:10



ne das Ändern von der Netzwerksicherheit bringt nichts, oder muss man dafür neustarten?

die DNS Adressen sind statisch und die IPs auch. Gut meine IPv6 Adresse ist nicht statisch, aber ich verbinde mich via IPv4 auf die Server und das Problem bestand auch schon in gleicher Form, als ich IPv6 noch nicht aktiv hatte.


greetz
Poison Nuke

kriztan

#4 Verfasst am 01.04.2011, um 22:11:55



Nabend. So richtig helfen kann ich leider auch nicht. Ich weiß aber, dass es unter Server 03 bzw. XP mal so ein Problem gab. Da lag es an einem Update des NET Framework bzw. einem Language-Pack. Leider weiß ich nicht mehr genau, um welches es sich handelte. Jedenfalls konnte man sich nach dem Update nicht mehr per RDP auf den Server schalten, es half nur eine Deinstallation des entsprechenden Updates. Hat mich damals so einnige Stunden, wenn nicht sogar Tage gekostet, das Spielchen, bevor ich wusste, woran es dann lag. Irgendwann gabs dann von MS ein neues Update, mit dem alles wieder funktionierte. Sind denn alle Updates aktuell? So wie ich das sehe, administrierst Du mehrere SRV2k8? Haben die alle den gleichen Updatestand?

LG Kriztan



 Poison Nuke  *

#5 Verfasst am 01.04.2011, um 22:59:30



das Problem zieht sich leider schon über mehr als ein Jahr :(. Die System sind alle immer auf dem aktuellsten Stand.

und da gab es mittlerweile so viele Updates zwischendurch, würde mich eigentlich fast wundern. Gut eine Option wäre, ich installiere mal komplett neu, nur das ist IMHO keine Option, da es ja auch andere Rechner mit dem Problem gibt und die Ursache des Problems wäre schon gut zu wissen


greetz
Poison Nuke

EPIC

#6 Verfasst am 02.04.2011, um 01:43:32



Das Problem kenne ich zum Glück nicht.

Wie sieht es denn mit der Struktur im Hintergrund aus. Also wie greifst du auf den Server zu?
(Server im Inet, Server erreichbar über VPN, erreichbar über LAN, Domänen mit Vertrauensstellung etc...)

Ich frage, da es gelegentlich Probleme bei WANs gibt, insbesondere was GPOs angeht. (Richtlinien werden nicht gezogen etc....) Evtl. gibt es da ähnliche Problem beim RDP.

Ich kenne da leider ein anderes Problem. Ich versuche mich über eine RDP-Sitzung an einem Server2003/2008/R2 anzumelden und habe leider keine Tastatureingabe mehr :D, da hilft zum Glück ein erneutes Anmelden.




 Poison Nuke  *

#7 Verfasst am 02.04.2011, um 11:10:07



die Server sind alle weltweit im Internet erreichbar. Allerdings ist das auch Standardeinstellung von Windows "öffentliche Netzwerke" ist die Standardeinstellung für die Firewall usw.


und das eigenartige ist ja, es geht ja mit dem ein oder anderen Win7 Rechner. Da muss irgendwas auf Clientseite nicht korrekt sein.

Ich versuche es nachher mal von meinem heimischen Win7 Rechner aus, aber ich glaube hier hatte ich das gleiche Problem. Daher vermute ich ja, dass ich da immer irgendwo irgendwas einstelle was mir hier jetzt ein Fallstrick ist, weil ein allgemeines Problem kann es wohl eher nicht sein, da es sonst weit mehr bei Google zu finden gäbe :L


greetz
Poison Nuke

 Poison Nuke  *

#8 Verfasst am 03.04.2011, um 00:00:39



eine sehr interessante Sache:

wenn das Passwort auf dem Server noch nicht geändert wurde (Also das Passwort dass nach sysprep vergeben wurde), dann funktioniert der Login immer.
Wenn aber das Passwort auf dem Server bereits geändert wurde (über RDP), dann funktioniert der Login per RDP von diesen spezifischen Win7 Clients nicht mehr.

Bei mir zuhause ist übrigens halt das gleiche Problem. Echt zum Verzweifeln


greetz
Poison Nuke

EPIC

#9 Verfasst am 03.04.2011, um 01:01:16



mh.. merkwürdig.

was sagen denn die gespeicherten Anmeldedaten auf den Clients? Irgendwelche alten Einträge die da nicht mehr hingehören?

Kannst ja mal "rundll32.exe keymgr.dll, KRShowKeyMgr" in die cmd eingeben. Ich bin mir aber jetzt nicht sicher ob RDP auch darauf Zugriff nimmt.



 Poison Nuke  *

#10 Verfasst am 03.04.2011, um 01:07:24



da sehe ich das gleiche wie unter

Start - Ausführen - "netplwiz" -> Erweitert -> Kennwörter verwalten
Bzw man kann auch in die Systemsteuerung auf Systemsteuerung\Anmeldeinformationsverwaltung gehen.

und wenn ich da manuell einen Eintrag für einen der Server hinzufüge, kann ich mich auch ohne Probleme sofort mit dem verbinden, ohne weitere Kennwortabfrage. Alle die da nicht drinstehen, da geht es nicht :Y



greetz
Poison Nuke

kriztan

#11 Verfasst am 03.04.2011, um 09:11:34



Schau mal in die Registrierung in diesen Schlüssel: HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Servers
Da stehen die ganzen RDP Server drin. Vielleicht sind da noch falsche Anmeldeinfos drin? Könntest ggf. mal versuchen die Einträge der betreffenden Server zu löschen. Aber Backup nicht vergessen


bearbeitet von kriztan, am 03.04.2011, um: 09:12:01


 Poison Nuke  *

#12 Verfasst am 03.04.2011, um 10:10:12



hm, das wäre nun der vierte Ort wo ich die Anmeldeinfos finde.
Allerdings besteht das Problem ja auch bei Servern, zu denen ich noch nie vorher Kontakt hatte und die entsprechend definitiv nirgendwo hinterlegt sind


greetz
Poison Nuke

PN's Forum \ Computer \ Software \ Betriebssysteme \ Windows \ Kein RDP Zugriff von Windows Vista / 7 Client auf Windows Server 2008 (R2)


- Zurück zur Homepage - Eigene Beiträge - Neue Beiträge - Wer ist online? - Impressum - Nutzungsbedingungen - Statistiken -



Board coded and provided by: Poison Nuke
Copyright 2007-2014, Robert Menger