Registrierung
leer
leer
newposts
Users
search
FAQ
Login
Start

Hallo Gast, und Willkommen im Forum. Sie müssen sich einloggen oder registrieren, um alle Funktionen nutzen zu können.


PN's Forum \ Computer \ Software \ Betriebssysteme \ Windows \ mit Win7 kein Zugriff auf TomatoUSB SMB-Server


User198 *

#1 Verfasst am 05.07.2013, um 10:30:11



Servus Leute,
hab mir einen Netgear 3500L(v1) zugelegt und TomatoUSB darauf installiert -> läuft alles wunderbar (AP, DLNA, FTP usw.)
Mit meinem Android-Stick hab ich auch auf den aktivierten Samba-Server Zugriff (wie konfiguriert lesend und schreibend), allerdings hab ich mit Win7 und dessen Windows-Explorer keinen Zugriff darauf. Hier mal ein Bild:




jetzt hab ich mich auch an diese Anleitung gehalten:
http://www.administrator.de/wissen/how-to%3a-mit...m-lan-46436.html

Eine Möglichkeit, warum das vlt nicht geht, ist der fehlende WINS-Proxy bei der IP-Config, welche auch auf "Nein" steht (ipconfig /all)
jedoch habe ich es nicht hinbekommen, dass da ein vernünftiger Eintrag drin steht.

Was meint ihr? Liegt es tatsächlich am WINS? Wie bekomm ich denn einfachen Zugriff auf den SMB-Server?

LG, Benni



 Poison Nuke 

#2 Verfasst am 05.07.2013, um 10:39:59



WINS hat damit absolut gar nix zu tun. Das ist auch völlig irrelevant in sämtlichen Netzwerken. Ein Relikt aus Urzeiten der Windows 95/98 Netzwerke.

Es hat auch grundsätzlich nichts mit Netzwerk oder der Art der Authentifizierung zu tun (der Schritt mit dem NTLMv2 usw war eher kontraproduktiv).
Wie in der Fehlermeldung

Zitat:
Der angegebene Server kann den angeforderten Vorgang nicht ausführen

liegt hier ein Problem beim Zugriff auf den eigentlichen Share vor.

Am einfachsten wäre es, wenn du ins Log schauen könntest von dem SMB-Server, da steht je nach Log-Level die eigentliche Fehlermeldung drin. U.u. eine Inkompatiblität der SMB-Versionen oder Dateisystem oder so.





greetz
Poison Nuke

User198 *

#3 Verfasst am 05.07.2013, um 21:28:18



mhh, okay, alles klar. so war das zumindest im tomato-forum beschrieben, aber dann schlag ich mir das mal wieder aus dem kopf.

installiert ist Samba-Version 3.0.24. Nach der Konfig und der Log werd ich jetzt mal schauen



\\hier nun die smb-konfig



Quellcode
[global]
 interfaces = br0
 bind interfaces only = yes
 workgroup = WORKGROUP
 netbios name = tomato
 server string = tomato
 guest account = nobody
 security = user
 map to guest = Bad User
 guest ok = yes
 guest only = no
 browseable = yes
 syslog only = yes
 timestamp logs = no
 syslog = 1
 dns proxy = no
 encrypt passwords = yes
 preserve case = yes
 short preserve case = yes
 wins support = yes
 domain master = yes
 local master = yes
 preferred master = yes
 os level = 65
 socket options = TCP_NODELAY SO_KEEPALIVE IPTOS_LOWDELAY SO_RCVBUF=16384 SO_SND



[root$]
 path = /
 writable = yes
 delete readonly = yes
 force user = root
- smb.conf 1/48 2%
[global]
 interfaces = br0
 bind interfaces only = yes
 workgroup = WORKGROUP
 netbios name = tomato
 server string = tomato
 guest account = nobody
 security = user
 map to guest = Bad User
 guest ok = yes
 guest only = no
 browseable = yes
 syslog only = yes
 timestamp logs = no
 syslog = 1
 dns proxy = no
 encrypt passwords = yes
 preserve case = yes
 short preserve case = yes
 wins support = yes
 domain master = yes
 local master = yes
 preferred master = yes
 os level = 65
 socket options = TCP_NODELAY SO_KEEPALIVE IPTOS_LOWDELAY SO_RCVBUF=16384 SO_SND



[root$]
 path = /
 writable = yes
 delete readonly = yes
 force user = root
 comment = Hidden Root

[share]
 path = /mnt
 writable = yes
 delete readonly = yes
 force user = root
 comment = Default Share

[Volume]
 path = /tmp/mnt/Volume
 comment = Volume
 writable = yes
 delete readonly = yes
 force user = root
- smb.conf 1/48 2%
[global]
 interfaces = br0
 bind interfaces only = yes
 workgroup = WORKGROUP
 netbios name = tomato
 server string = tomato
 guest account = nobody
 security = user
 map to guest = Bad User
 guest ok = yes
 guest only = no
 browseable = yes
 syslog only = yes
 timestamp logs = no
 syslog = 1
 dns proxy = no
 encrypt passwords = yes
 preserve case = yes
 short preserve case = yes
 wins support = yes
 domain master = yes
 local master = yes
 preferred master = yes
 os level = 65
 socket options = TCP_NODELAY SO_KEEPALIVE IPTOS_LOWDELAY SO_RCVBUF=16384 SO_SND



[root$]
 path = /
 writable = yes
 delete readonly = yes
 force user = root
 comment = Hidden Root

[share]
 path = /mnt
 writable = yes
 delete readonly = yes
 force user = root
 comment = Default Share

[Volume]
 path = /tmp/mnt/Volume
 comment = Volume
 writable = yes
 delete readonly = yes
 force user = root
~
~
~
- smb.conf 1/48 2%



bearbeitet von User198, am 05.07.2013, um: 21:40:35


User198 *

#4 Verfasst am 11.07.2013, um 14:33:50



nach einem Firmware-update funktioniert nun auch der Zugriff drauf :-)
sonst hab ich keine Änderung am SMB-Server gemacht


PN's Forum \ Computer \ Software \ Betriebssysteme \ Windows \ mit Win7 kein Zugriff auf TomatoUSB SMB-Server


- Zurück zur Homepage - Eigene Beiträge - Neue Beiträge - Wer ist online? - Impressum - Datenschutz - Statistiken -



Board coded and provided by: Poison Nuke
Copyright 2007-2014, Robert Menger